Symptom:
There is an error when attempting to use an S3 bucket that was just created in a cloud storage group.
Cause:
Amazon does not propagate credentials in a timely manner. So the system is given a 307 error.
Resolution:
Admin may have to wait up to an hour after creating the S3 bucket before using it in a CSG.
No further action is required. Just wait longer time until the credential propagation is completed.
If the issue is not resolved over extended period of time, contact Morro support for assistance by submitting a support ticket.