Symptom:
User cannot access a share even though they have the correct credentials with access permissions.
User cannot access a share even though they have access permission and are using the correct credentials.
User connects to a share with "Allow guest access" enabled and then cannot connect to a share drive to which they have access permission using their credentials.
Example: There are two shares in the team called share1 and share2. share1 has guest access enabled. share2 allows User1 to access. The user connects to share1, which connects as the "Guest" and then receives an error when attempting to connect to share2 with their correct credentials.
User cannot access a different share on the same gateway using two different user credentials.
User connects to a share using the user credentials to which they have access rights. The user tries to connect to a different share on the same gateway to which they do not have access rights and attempts to use a different set of user credentials that does have access rights. The system will display an error.
Example: There are two shares in the team called share1 and share2. User1 has access to share1 and User2 has access to share2. A user connects to share one using their credentials User1. Then, the user attempts to connect to share2 using credentials from User2.
Error in Windows
"<\\server name\share name> is not accessible. You might not have permission to use the network resource. Contact the administrator of this server to find out if you have access permission.
Multiple connections to a server or shared resource by the same user, using more than one user name, are not allowed. Disconnect all previous connections to the server or shared resource and try again."
Error in OS X
"The operation can't be completed because the original item for <share name> can't be found."
Cause 1:
If you are in "Morro Users Mode", make sure the name of the Workgroup in the MCM matches that of the name of the PC's workgroup.
Go to Morro Cloud Manager > Team > Authentication, and change the Workgroup name to the correct name.
Please also reference this article https://morro.freshdesk.com/support/solutions/articles/14000097321-morro-users-mode for more information.
Cause 2:
This is a known limitation in OS X and Windows operating systems.
If the user has connected to a share without entering a credentials, it is possible they have connected as a Guest user.
Note: In Windows, the system will also attempt to connect using the credentials of the logged in user to the Windows system. If the credentials are accepted by the network share, the user will be connected without having to enter their credentials. If the credentials do not match, Windows will attempt to connect with Guest access.
Once the user is connected as a Guest user, an attempt to connect to a share using their user credentials will result in the error.
If the user is already connected to a network share using a set of credentials. The system does not allow the user to connect to another network share on the same server with a set of credentials different than the one used to connect to the first share. This affects both operating systems.
Resolution:
Disconnect or eject the share connected with the Guest user or with the user credential they no longer wish to user. If after disconnecting and the problem still persists, reboot the system and connect to the share with the intended credentials
Disconnect from the first share. Some systems may require the user to reboot their client computer to disconnect the user credentials used to access the first share.
For Windows users, open a Powershell window and use the following command:
net use
This will list all current connections to network shares. To delete a network share connection, use the following:
net use \\$hostname\$share /delete
Replace $hostname with the IP address or hostname of the CacheDrive and $share with the name of the share. As a shortcut, you can delete all network share connections as follows:
net use * /deleteIf the "net use" command in #3 shows an empty list but you still get the error message, restarting the Workstation service can help:
* Right-click on the Start Menu and select Run. Enter services.msc in the dialog box and click OK.
* Scroll down the services list and right-click on Workstation, then select Restart.In some newer versions of Windows 10, the login name needs to be prefixed with the device name. For example, if the CacheDrive's hostname is MorroDrive, try logging in as MorroDrive\myusername.
More Information:
https://morro.freshdesk.com/support/solutions/articles/14000097321-morro-users-mode