Symptom:
User connects to their device but files are synced to the wrong device.


Cause:

It is possible to create two devices with the same name on the same network if users have more than one team. If this happens, when users attempt to connect to the SMB share for the device associated with their team, they may end up connecting to the device on the other team. This will cause confusion as files are written to one device when intended to be written to the other. 


Resolution:

To fix this issue, rename one of the devices in the team and have users reconnect their shares.


More Information:

As a guideline, all gateways on the same network should have different names regardless of team to avoid naming conflicts.