Symptom:

Admin cannot discover the device (CacheDrive or xCache Expansion) during Add Gateway, Add xCache Expansion, or Account Sign-Up


Cause:

There are a few common causes for the device to be not discovered.

  1. Device has been turned on too long without being added to an accounts.
  2. Device is not powered on.
  3. Device is not connected to network.
  4. Device is not connected to the correct network


Resolution:

To fix this issue, perform the following actions for the corresponding cause.


1. Device has been turned on too long without being added to an accounts.
The system has a security feature that prevents the device from being claimed by an unauthorized user. If the device has been powered on for more than 2 hours, it will no longer be discoverable. To set the device back to "discoverable", power the device off and power it on. To power off the device, press the power button and release. After 5 seconds, the device will power off. Power the device back on and wait 5 minutes for the initialization to complete, then try to add the device again.


2. Device is not powered on.

Make sure the device is powered on. Choose the country correct plug and plug the device in. Check that the blue LED is on. For the G40 and CX2, the power LED is on the power button. For the G80, the power LED is on the front panel near the audio plug.


In some cases, the device power LED will be on, but the device is in a suspended state. To fix this issue, power cycle the device by powering it off and powering it back on again.


3. Device is not connected to the network.

Make sure the device is connected to your network and that the network has access to the Internet. The device needs to communicate with the Morro Cloud.


4. Device is not connected to the correct network.

If the device is being installed on the local network, check that the device is connected to the same network segment as the client used to add the device. A common issue is that the client is on a WiFi network that is not accessible by the wired network. 


If the device is not accessible by the network to which the client is connected, the device can be added using the remote setup procedure. In the Add Device panel, select "Locate by UUID". Obtain the UUID from the sticker on the bottom of the device and enter it into the UUID field. Then click Add.


More Information:

For more information on adding a CacheDrive, reference the article: Add Gateway.

For more information on adding an xCache Expansion, reference the article: Add xCache Expansion.

For more information on creating an Account, reference the article: Morro Account Sign Up.